54 lines
1.7 KiB
Nix
54 lines
1.7 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{ config, lib, pkgs, modulesPath, ... }:
|
||
|
||
{
|
||
imports =
|
||
[ (modulesPath + "/installer/scan/not-detected.nix")
|
||
];
|
||
|
||
boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "ahci" "usbhid" "usb_storage" "sd_mod" ];
|
||
boot.initrd.kernelModules = [];
|
||
boot.kernelModules = [
|
||
"kvm-amd"
|
||
];
|
||
boot.extraModulePackages = [ ];
|
||
|
||
# Setup Nvidia Driver
|
||
hardware.graphics.enable = true;
|
||
hardware.nvidia =
|
||
{
|
||
modesetting.enable = true;
|
||
powerManagement.enable = false;
|
||
powerManagement.finegrained = false;
|
||
open = false;
|
||
nvidiaSettings = true;
|
||
package = config.boot.kernelPackages.nvidiaPackages.beta;
|
||
};
|
||
|
||
# Enable Bosto Tochpad Support (See ../../../modules/nixos/hardware/bosto-touchpad/default.nix)
|
||
hardware.bosto-touchpad.enable = true;
|
||
|
||
fileSystems."/" =
|
||
{ device = "/dev/disk/by-uuid/b3344eaa-384e-4779-92b8-92f6e9a27d7d";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
boot.initrd.luks.devices."luks-11c71284-504f-4b84-a944-265ad793b139".device = "/dev/disk/by-uuid/11c71284-504f-4b84-a944-265ad793b139";
|
||
|
||
fileSystems."/boot" =
|
||
{ device = "/dev/disk/by-uuid/3C1C-72D5";
|
||
fsType = "vfat";
|
||
options = [ "fmask=0077" "dmask=0077" ];
|
||
};
|
||
|
||
swapDevices = [ ];
|
||
|
||
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
|
||
networking.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.enp9s0.useDHCP = lib.mkDefault true;
|
||
|
||
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
||
hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
||
}
|